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About this Document  
This booklet provides instructions for installing and starting MARC Magician Professional. It also provides a brief 
overview of MARC Magician Professional's basic functionality. Detailed information about MARC Magician 
Professional can be found in the extensive program Help. To view MARC Magician Professional Help, click the Help 
menu and then click Help Topics.  

About the Program  
This section briefly explains how MARC Magician Professional works. It also lists the minimum system requirements 
for installing and using MARC Magician Professional.  

What is MARC Magician Professional?  
You ask, “What is MARC Magician Professional?”  We answer, “What do you want to do with your library database?”  

Consider the following problems:   

• Do you have subject headings that you’d like to change, such as “Afro American” or “Indians of North 
America?”  

• Are there inconsistencies in your call numbers?  

• Are you a librarian who doesn’t have the time to memorize the MARC codes and rules to catalog or fix 
records?  

• Are you a veteran cataloger whose chief concern is to maximize value and search ability of the library’s 
materials?  

• Have you ever needed to perform global/batch editing that could not be performed by your automation 
system?  

• As a K-12 school librarian, are you concerned about putting off students who see juvenile literature in your 
subject headings?  

• Is your library not yet automated, and you want to print catalog cards and/or spine labels and create a 
MARC record database for future use?  

 

MARC Magician Professional can be used to solve all these needs and many more.  

So what is MARC Magician Professional? The MARC Solution.  
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Features  

Global editing  
Global editing is a very fast and powerful way to clean up MARC records. For more detailed information, see the 
MARC Magician Professional Help.  

MARC Magician Professional provides global editing commands for:  

• Checking spelling (American, British, French, and Spanish dictionaries)  
• Finding and replacing text  
• Changing the material type (for example, changing books to videos)  
• Deleting fields, subfields, and unwanted subject headings  
• Converting uppercase fields to correct capitalization  

 

Active Error Checking  
Active Error Checking™ is a unique feature that helps you spot potential problems with your records. It flags records 
that don’t meet certain criteria and shows you what you need to do to fix them. In the program options you can 
define what sorts of mistakes and omissions should be considered errors. 

Easy cataloging  
The MARC Magician Professional Cataloger supports you in every aspect of your original cataloging work. Now you 
can create quality MARC records without learning complicated MARC rules.  

• Information panels provide real-life examples, cataloging tips, and AACR2 rule numbers for most subfields. 
The Active Error Checking panel lets you know whether each record you create meets the cataloging 
standards you specify.  

• Check the spelling of your records using American, British, French, and Spanish dictionaries.  

• MARC Magician Professional automatically sets non-filing indicators and inserts the correct ISBD 
punctuation.  

• Standard templates cover every type of library material you catalog. If the standard templates lack a field 
that you use often, you can add the field to all standard templates at once or create your own custom 
templates.  

• The Cataloger’s Reference (found in the Help Topics) provides in-depth information and examples for most 
MARC fields and subfields right on your screen.  

Other features  
• The MARC Magician Professional Help Topics contain detailed program information in an organized, easy-

to-use manner. Topics include specific instructions for getting your records into and out of MARC Magician 
Professional, and a Cataloger’s Reference that contains detailed cataloging information.  

• The Record Viewer allows you to browse through a large number of records quickly. It is the best way to 
check your records before exporting or printing them.  

Automatic record repair  
When you import records, MARC Magician Professional automatically checks them for structural accuracy and 
corrects ISBD punctuation, non-filing indicators, GMD, invalid indicators, and invalid control fields.  
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Starting the Program  
 
To start the program, double-click the MARC Magician Professional icon on your Desktop, or click the Start button, 
point to Programs, click MARC Magician Professional, and then click MARC Magician Professional. 

You will see the Startup Wizard (Magician rolling out a red carpet). Make sure to enter the access key that you 
received for MARC Magician Professional. The Startup Wizard helps you to choose some of the options that you 
need when you work with MARC Magician Professional. Follow the instructions on your screen.  

Using MARC Magician Professional to Create, 
Edit, and Organize Records  
This section provides a brief introduction to MARC Magician Professional and gives you a general idea of how the 
program is organized. It does not explain everything there is to know about MARC Magician Professional, but after 
reading this section you should understand the basic structure of the program and feel confident exploring it 
further on your own. The MARC Magician Professional Help Topics contain detailed information about the program, 
including import and export instructions and a Cataloger’s Reference Guide. You can also look at the Tutorials in 
the Support section of our web site, www.mitinet.com, for step-by-step examples.  

MARC Magician Professional Overview  
This section covers four essential parts of the program: the Main Window, the Cataloger, the Record Viewer, and 
the Help system.  

The Main Window  
The Main Window is the first thing you see once you get into the program. It is where you begin and end all of the 
things you do in MARC Magician Professional. The Main Window is present whenever the program is running. 
When you close the Main Window, you exit the program.   

Menus

Status Bar

Master List

Weeding Truck 
(minimized list) 

Toolbar
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Like most Windows programs, MARC Magician Professional has a row of menus (File, Edit, View, etc.) and a toolbar 
with buttons for commonly used commands. The status bar appears at the very bottom of the Main Window. It 
shows information about how many records you have and how they are sorted.   

Lists occupy most of the Main Window. A list is a group of records, organized in rows and columns. Each record 
takes up one row, and each column shows a particular aspect of the record, such as the author or title. Each list is a 

separate window inside the Main Window. These windows can be resized using the maximize   and minimize  

buttons in the top right corner of the window. They cannot be closed, so the close   button is dimmed.   

MARC Magician Professional always has at least two lists: the Master List and the Weeding Truck. The Master List is 
the complete list of records in the MARC Magician Professional database. The Weeding Truck is like the Microsoft 
Windows Recycle Bin: when you delete records from the Master List, they go into the Weeding Truck.   

To switch between lists, open the List menu (or the Window menu) and click the list you want to switch to.  

The Cataloger  
The Cataloger is the window that you use to create and edit MARC records. To open a record in the cataloger, 
double-click it in the Master List.  

 
Like the Main Window, the Cataloger has menus, a toolbar, and a status bar. The record is displayed in a separate 
window inside the Cataloger.   

The buttons with the numbers and letters on the left side of the window are the MARC field tags and subfield 
codes. These can be clicked to display a menu of the commands available for the current field or subfield. You don’t 
have to know what the numbers and letters mean, because whenever you put the insertion point in an empty field, 
MARC Magician Professional displays a prompt that tells you what information is called for.   
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The boxes that appear alongside the record window are information panels. The text in most panels changes 
when you move the insertion point to a different subfield. If you don't need a  

panel, you can close it by clicking the   in the top right or left corner of the panel. To reopen a panel, click the 
View menu and then select the panel you want to display.  

When you close the Cataloger, you return to the Main Window.   

For a step-by-step cataloging exercise, see the MARC Magician Tutorial 1 - Cataloging Basics, in the Support section 
of our web site, www.mitinet.com.  

The Record Viewer  
The Record Viewer is a special window that you can use to check your records. It is convenient for this purpose 
because you can quickly page from one record to the next. Also, you can have an unlimited number of records 
open in the Record Viewer, whereas in the Cataloger you can only have ten open at a time. To open the Record 

Viewer, select the records you want to view in the Master List, and then click the Record Viewer button  on the 
toolbar.  

 
 

While working in the Record Viewer, you can print records, open a record in the Cataloger for editing, and export 
records. For a step-by-step Record Viewer exercise, see the MARC Magician Tutorial 5 -Working with the Record 
Viewer, in the Support section of our web site, www.mitinet.com.  
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The Help system  
The Help system is an important part of MARC Magician Professional because it is a thorough and up-to-date 
source of information about how to use MARC Magician Professional. Help is displayed directly on your computer 
screen. It provides complete instructions for working with the program as well as general cataloging advice and 
detailed explanations of MARC fields and subfields. There are three basic parts to Help:  

1. General help topics: The general help topics include overviews, step-by-step instructions, and a glossary of 
technical and cataloging terms. You can find topics using the table of contents, the index, or a full-text search. 

To get to general help topics, click the Help button    on the toolbar, or press the F1 key on your keyboard.  

2. Dialog box help: Most dialog boxes have a Help button in the lower right corner. When you have a dialog box 
open, you can click the Help button or press the F1 key to display an explanation of how to use the dialog box.  

3. Cataloger’s Reference: The Cataloger’s Reference provides general cataloging advice and details about most 
MARC fields, including examples and information about subfields and indicators. When you are working in the 
Cataloger, you can open the Cataloger’s Reference topic for a specific field by clicking the tag of the field you 
want help with, and then clicking Help.  
 

Bringing records into MARC Magician Professional  
Before you can clean up or customize existing records using MARC Magician Professional, you have to bring them 
into MARC Magician Professional. Imported records get added to the Master List along with the records already 
there. Once you have imported them, you can work with them in all the same ways that you work with records you 
create.  

How you transfer records depends on where the records are located:  

• In your library automation system database: These are records in your library automation system that 
have not yet been exported. Bringing these records into MARC Magician Professional is a two step process: 
first you export a copy of them from your library automation system (see your library automation system 
documentation or the MARC Magician Professional Help), then you import them into MARC Magician 
Professional using the Import command on the File menu.   

• In a file on your computer: These are records downloaded from the Internet (such as the Library of 
Congress or a state database), or records that have already been exported from your library automation 
system and saved on the hard disk of your computer or another computer on the same network. To bring 
these records into MARC Magician Professional, you simply import the file using the Import command on 
the File menu.  

• On a CD or floppy disk: These may be records from a vendor or records that have already been exported 
from your library automation system and saved on a CD or floppy disk. To bring these records into MARC 
Magician Professional, you simply import the file using the Import command on the File menu.  

• In Follett Catalog Plus or Mandarin: If you use either of these library systems, you can use the EZ Transfer 
feature built into MARC Magician Professional and Follett Catalog Plus or Mandarin to transfer your records 
to MARC Magician Professional. EZ Transfer is a two-step process: 1) EZ Transfer to get records out of 
Follett/Mandarin; 2) EZ Retrieve to bring records into MARC Magician Professional. You can find complete 
step-by-step instructions in the Help Topics.  
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Editing Individual Records Using the Cataloger  
In the Cataloger, you can edit subfield text using your keyboard as you would in a word processing program. You 
can also add, delete, and change fields and subfields.   

To... Do this... 

Add a field  Click the Add Field  button on the toolbar, and then select the field you want.  

Add a subfield  
Put the insertion point anywhere in the field you want to add a subfield to. Click the Add 

Subfield  button on the toolbar, and then select the subfield you want.  

Delete a field  
Put the insertion point anywhere in the field you want to delete, and then click the 

Delete Field  button on the toolbar.  

Delete a 
subfield  

Put the insertion point in the subfield you want to delete, and then click the Delete 

Subfield  button on the toolbar.   

Duplicate a field  
or subfield Click the field tag or subfield code, and then click Duplicate.  

Change a field  
or subfield  

Click the field tag or subfield code, and then click Change. Select the field or subfield you 
want to change to.  

 
For a step-by-step cataloging exercise, see the MARC Magician Tutorial 2 – Editing Records, in the Support section of 
our web site, www.mitinet.com.  
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Editing Several Records at a Time (Global Editing)  
Global editing is a very fast and powerful way to clean up MARC records. MARC Magician Professional provides 
sixteen commands that you can use to make global changes to your records, including adding a field, finding and 
replacing text, fixing capitalization, and much more. This document only provides a very basic outline of the global 
editing procedure. For more detailed information, see the MARC Magician Professional Help.   

Basic procedure for global editing  
1. Select the records you want to work with (see table below).  

To...  Do this...  

Select a single record  Click the record.  

Select all records  
in the list  

On the Select menu, click All Records.  

Select a block of consecutive 
records  

Click the first record in the block, and then press the Shift key and hold it down. 
Click the last record in the block, and then release the Shift key.  

Select multiple nonconsecutive 
records  

Press the Ctrl key and hold it down. One by one, click each record you want to 
select, and then release the Ctrl key.  

Select records based on 
whether they fulfill certain 
criteria  

On the Select menu, click the command you want. In some cases a dialog box 
will appear, prompting for more information. Previous selections will be 
removed.  

Deselect all records  
Click somewhere else in the list. The record you click on will be selected, but all 
other records that were previously selected will no longer be selected.  

Deselect a single record  
Press the Ctrl key and hold it down. Click the record you want to deselect, and 
then release the Ctrl key.  
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2. Click the Global Editing   button on the toolbar, and then choose the command you want. A dialog box 
appears. (The following example shows a Find and Replace command that will remove Juvenile Literature from 
your Subject Headings.)  

 

3. Provide information about the change you want to make, and then click OK.  

The Make Change dialog box will appear for each potential change. This allows you to see how each record will 
change before the change is actually made. You should always review at least the first few changes. If you are 
satisfied with the way the command is working, you can click Change All to make the change in all of the selected 
records, without further prompting.  

For step-by-step Global Editing exercises, see the MARC Magician Tutorial 7 – Global Editing Basics, and MARC 
Magician Tutorial 8 – Advanced Global Editing, in the Support section of our web site, www.mitinet.com.  

 

 

 

 

 
 

 

Important  
Global editing is powerful stuff. You can fix a lot of errors in a very short time – but you can also do 
a lot of damage. You should get in the habit of making a quick backup of your records before you 
do a global editing task -- just click on the File menu and then click Backup Database. That way, if 
you make a mistake, you can easily restore the database to its previous condition by clicking File 
and then clicking Restore Database. Remember that you are editing records in MARC Magician 
Professional, not in your library automation system’s database. Changes made to records won’t 
reflect in your library system’s database until you transfer them back into your library system.  
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Creating Original MARC Records  
Every record in MARC Magician Professional is based on a template that corresponds to the type of material (book, 
videocassette, etc.). To create a new record:  

1. On the Record menu, click New Record. The Select Template dialog box appears.  

2. Select the template you want, and then click OK.  
The Cataloger opens, displaying a blank record. The buttons with the numbers and letters on the left side of the 
window are the MARC field tags and subfield codes. The blinking vertical line is the insertion point, which 
shows where the characters you type will appear on the screen. Next to that you see the cataloging prompt, 
which tells you what information belongs in the current subfield.   

3. Type the main entry, title, publication information, etc. in the appropriate fields and subfields.  

4. Enter holdings information (call number, bar code, location, price, etc.) as follows:  
 

If you use Easy Entry holdings, click the Holdings    button on the toolbar to enter holdings information.   
 
If you use Custom holdings, the holdings field (usually 852) appears in the record window along with the rest of 
the fields. Enter the holdings information as you would in any other field.  

5. Save the record by clicking the Save   button on the toolbar.  
 

6. To close the record, click the   in the upper right corner of the record window. Unless you want to catalog 
another item, it's usually a good idea to close the Cataloger and return to the Main Window.   
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Transferring Records from MARC Magician Professional to 
Your Library Automation System  
When you are finished creating original records or cleaning up existing records with MARC Magician Professional, 
you can export the records out of MARC Magician Professional, and then bring them into your library automation 
system.   

For Follett Catalog Plus or Mandarin  
If you use either Follett Catalog Plus or Mandarin, you can use the EZ Transfer feature built into MARC Magician 
Professional and Follett Catalog Plus or Mandarin to transfer your records from MARC Magician Professional to your 
library system. EZ Transfer is a two-step process: 1) EZ Transfer to get records out of MARC Magician Professional; 2) 
EZ Retrieve to bring records into Follett/Mandarin. You can find complete step-by-step instructions in the Help 
Topics.  

For other library systems  
Here’s the basic procedure for exporting records:  

1. Select the records you want to export.  

2. On the File menu, click Export Records.  
 
If any of the records you selected contain export errors, a dialog box will appear, asking whether you want to 
export all records or only those without export errors. After you make your choice and click OK, the Export 
dialog box appears.  

3. Specify a file name and location for the records, and then click OK.  
 
A copy of the records is saved to a file, which you can now import into your library automation system. The 
records also remain in MARC Magician Professional. You can delete them from the MARC Magician Professional 
database if you are finished with them.   

4. Import the file into your library automation system. For detailed instructions, see the documentation that came 
with your system. The MARC Magician Professional Help also contains import instructions for many systems.  
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MARC Magician Tutorials  
 

• Do you want to get a head start with Cataloging?  
• Would a few walk-through examples of Global Editing help you?  
• Do you need some help getting your Active Error Checking set up?  
• Do you want to learn how to use Templates to save you time?  

 

If you answered “yes” to any of those questions, the MARC Magician Tutorials are just what you need! You can find 
them in the Support section of our web site, www.mitinet.com. Go take a look – they’re a great way to get started 
using MARC Magician Professional! Here’s a brief overview of the tutorials:  

Tutorial 1: Cataloging Basics  
• Create new records.  
• Enter cataloging information in fields and subfields.  
• Enter holdings information.  

 
Tutorial 2: Editing Records  

• Add, delete, and change fields and subfields.  
• Check spelling.  

 
Tutorial 3: Building Your Own Templates  

• Create a new custom template  
 
Tutorial 4: Working with Lists  

• Sort and select records.  
• Find specific records in the list.  
• Create your own record lists.  

 
Tutorial 5: Working with the Record Viewer  

• Open, Browse, and Print your records.  
 
Tutorial 6: Finding Potential Problems – Active Error Checking  

• Set Active Error Checking options and see how to monitor your records.  
 
Tutorial 7: Global Editing Basics  

• Find and replace text in a group of records.  
• Add a field to a group of records.  
• Fix the capitalization of fields or subfields that are all in upper case.  

 
Tutorial 8: Advanced Global Editing  

• Globally change a field.  
• Use the “get text” feature to copy text from another part of the record.  

 


